Game:

The Spam Club

» The Spam Club - Deutsche Kategorie - Deutsches Forum - Frage zum Forum - Support Spamboard? - Reply

Reply

Username:
Not Authentication Code (blank):
Password:
Guest Password: JEljL
Post:
Attachment: (max. 5000000 bytes)
Mail Notification?Yes
No

Last 20 Posts (View All)

Posted at 19:28 on July 3rd, 2009 | Quote | Edit | Delete
Avatar
Member
Bachelor Gumby
Posts: 73
OK - geht - hab jetzt die ganze 112 gelöscht und deine Zeile reinkopiert und nun gehts. Keine Ahnung was ich da wieder verpeilt hatte - ich glaub ich werde einfach alt.

Oh und keine Angst ich werde dir jede Ungereimtheit die ich finde unter die Nase reiben :P
-----
Never be afraid to try something new. Remember that amateurs built the Ark. Professionals built the Titanic.
Posted at 19:11 on July 3rd, 2009 | Quote | Edit | Delete
Avatar
Admin
Reborn Gumby
Posts: 8814
Als die Änderung habe ich natürlich geprüft und für funktionierend befunden. Um dir dann nochmal ein bisschen Kontext zu geben, wie es nachher aussehen soll:

Code:
// default, non-modifyable groups
$form->addRawTableRow(Array('<td><input name="changegroupname[' . $row['id'] . ']" type="text" value="' . $STATUS[$row['name']] . '" disabled="disabled" /></td>', '<td><input name="changegrouppublic[' . $row['id'] . ']" type="checkbox" value="1" disabled="disabled" /></td>', ' ', '<td><a href="' . $F->link('permissions') . 'id=' . $row['id'] . '">' . $LANG['Edit'] . '</a></td>'));


Das Ganze ist im Übrigen allerdings rein kosmetisch. Dieser Fehler hat keinerlei Einfluss auf die eigentliche Funktionalität und der Gruppenname sollte im öffentlichen Teil des Forums auch korrekt angezeigt werden.

Übrigens, bevor du fragst: Ja, die Gruppennamen sind auf der Seite, auf der man die Rechte vergibt, nicht übersetzt - ein weiterer Fehler, aber wiederum rein optisch. Diesen ganzen komplizierten "Status"-Schrabbel werde ich ohnehin abschaffen in naher Zukunft, und dann alles über Gruppen abwickeln (siehe Ticket auf der Projektseite). In dem Rahmen werden solche "Altlasten" dann automatisch verschwinden. Was natürlich nicht bedeuten soll, dass du keine Fehler mehr melden sollst ;)
-----
Now you see the violence inherent in the system!
-----
Edited by Mr Creosote at 19:16 on July 3rd, 2009
Posted at 18:57 on July 3rd, 2009 | Quote | Edit | Delete | Delete Attachment
Avatar
Member
Bachelor Gumby
Posts: 73
Mist, der Editor ist super aber es scheint für mich einfach schon zu spät am Tag zu sein um noch was "tun" zu können.

Ich glaub ich hab das jetzt richtig abgeändert - aber es hat nicht so ganz geholfen - siehe Bild.

Wahrscheinlich hab ich aber nur mal wieder was verschußelt :(

Ich geh glaub ins Bett und versuch das Morgen oder Übermorgen nochmal richtig zu machen ;)
Aber hey - einmal mehr Danke für deine schnelle Reaktion :)
Attachment: *****
-----
Never be afraid to try something new. Remember that amateurs built the Ark. Professionals built the Titanic.
Posted at 18:28 on July 3rd, 2009 | Quote | Edit | Delete
Avatar
Admin
Reborn Gumby
Posts: 8814
Mist... da hab ich tatsächlich etwas übersehen. Aber zumindest kannst du dann ja mal gleich deinen neuen Editor produktiv einsetzen ;)

In der Datei admin/classes/pages/Groups.php kannst du Zeile 111 ersatzlos streichen und in der folgenden Zeile "$STATUS[$_translated_name]" mit "$STATUS[$row['name']]" ersetzen.
-----
Now you see the violence inherent in the system!
Posted at 17:46 on July 3rd, 2009 | Quote | Edit | Delete | Delete Attachment
Avatar
Member
Bachelor Gumby
Posts: 73
Konnte doch nicht bis Sonntag warten :P

Habe alles frisch installiert aber irgendwie stimmt das glaube ich etwas nicht ganz bei den "User Groups", denn bei Supermoderator steht nichts drin - weder wenn ich auf englisch stelle noch wenn ich deutsch einstelle... -> siehe Anhang.

Zumindest in der de.php steht aber drin
Quote:
$STATUS['Global Moderator'] = 'Globaler Moderator';
Attachment: *****
-----
Never be afraid to try something new. Remember that amateurs built the Ark. Professionals built the Titanic.
-----
Edited by traeumer at 17:47 on July 3rd, 2009
Posted at 16:57 on July 3rd, 2009 | Quote | Edit | Delete
Avatar
Member
Bachelor Gumby
Posts: 73
Hurra, werde ich am Sonntag mal überprüfen :D

- Hab mir übrigends einen Texteditor mit Zeilennummern besorgt :) - Nennt sich Textwranger und funktioniert recht ordentlich :)
-----
Never be afraid to try something new. Remember that amateurs built the Ark. Professionals built the Titanic.
-----
Edited by traeumer at 17:27 on July 3rd, 2009
Posted at 18:49 on July 2nd, 2009 | Quote | Edit | Delete
Avatar
Admin
Reborn Gumby
Posts: 8814
Version 5.1.3 ist draußen und sollte all deine Probleme (zumindest diejenigen, die du genannt hast) beheben.
-----
Now you see the violence inherent in the system!
Posted at 22:10 on June 26th, 2009 | Quote | Edit | Delete
Avatar
Admin
Reborn Gumby
Posts: 8814
Originally posted by moo2 at 07:55 on June 26th, 2009:
Ich habe nie behauptet das es Sinn machen würde bei den Gruppen bsw. die Moderatroen als "öffentlich" zu schalten - aber hey - ich bin doch admin - sollte ich nicht alles dürfen, auch wenn ich mir damit selbst ins "Bein schieße"? :P

Nö - du bist schließlich "Admin" und nicht "root".

Originally posted by moo2 at 07:55 on June 26th, 2009:
Sooo dringend ist der Patch nicht- ich setze das boad ja in keiner "Produktivumgebung" ein(keine user ;)) sonder spiele nur damit rum :)

Alle Änderungen kannst du dir natürlich auch aus dem Subversion-Repository holen...

Originally posted by moo2 at 07:55 on June 26th, 2009:
Hab mir sogar schon so einen css editor angeschafft - mal gucken ob ich aus dem Grün ein Blau machen kann ;)

Wenn du was Brauchbares hinbekommst, schick's mir - dann übernehme ich das (sofern du zustimmst) mit als Alternative in die "offiziellen" Versionen :)
-----
Now you see the violence inherent in the system!
Posted at 07:55 on June 26th, 2009 | Quote | Edit | Delete
Avatar
Member
Bachelor Gumby
Posts: 73
Ich habe nie behauptet das es Sinn machen würde bei den Gruppen bsw. die Moderatroen als "öffentlich" zu schalten - aber hey - ich bin doch admin - sollte ich nicht alles dürfen, auch wenn ich mir damit selbst ins "Bein schieße"? :P

Sooo dringend ist der Patch nicht- ich setze das boad ja in keiner "Produktivumgebung" ein(keine user ;)) sonder spiele nur damit rum :)

Hab mir sogar schon so einen css editor angeschafft - mal gucken ob ich aus dem Grün ein Blau machen kann ;)
-----
Never be afraid to try something new. Remember that amateurs built the Ark. Professionals built the Titanic.
Posted at 07:18 on June 26th, 2009 | Quote | Edit | Delete
Avatar
Admin
Reborn Gumby
Posts: 8814
Nein, mit der Anzahl der Benutzer hat das nichts zu tun. Als öffentlich kannst du jede Gruppe definieren, die du selbst angelegt hast - unabhängig davon, wie viele Benutzer jener Gruppe angehören.

Die "mitgelieferten" Gruppen kann du nicht als öffentlich definieren, weil das überhaupt keinen Sinn ergäbe! "Mitglied" ist ohnehin "öffentlich" sobald du Neuregistrierungen erlaubst (Registrierung = Beitritt in die Gruppe). "Gast" ist ohnehin immer "öffentlich": Einfach das Forum besuchen, ohne sich einzuloggen. Moderatoren, globale Moderatoren und Admin "öffentlich" zu machen wäre schlicht und einfach das Dümmste, was man anstellen kann. Wenn sich jeder selbst zum Admin machen kann, wird dein Forum nicht lange durchhalten ;) Deshalb sind die Checkboxen bei eben diesen Gruppen deaktiviert.

Brauchst du übrigens dringend einen Fix für den Gruppennamenbug? Habe den behoben, aber die Änderungen umfassen doch ein paar Dateien und jeweils mehrere Zeilen. Ich bringe sonst in den nächsten Tagen (Wochenende?) eh Version 5.1.3 raus, dann bekommst du's automatisch ;)
-----
Now you see the violence inherent in the system!
-----
Edited by Mr Creosote at 07:20 on June 26th, 2009
Posted at 04:24 on June 26th, 2009 | Quote | Edit | Delete
Avatar
Member
Bachelor Gumby
Posts: 73
Oh das mit dem "öffentlich" ist mir jetzt doch etwas peinlich :(
Wer lesen kann ist halt klar im Vorteil - ich gelobe Besserung.

Das ich den Hacken öffentlich bei keiner der Gruppen setzen kann wird wohl daran liegen dass ich nur den einen User (den Admin) habe und noch keine User in den anderen Gruppen nehme ich an.
-----
Never be afraid to try something new. Remember that amateurs built the Ark. Professionals built the Titanic.
Posted at 20:12 on June 25th, 2009 | Quote | Edit | Delete
Avatar
Admin
Reborn Gumby
Posts: 8814
Originally posted by moo2 at 19:54 on June 25th, 2009:
Quote:
Die Übersetzungen der Gruppennamen sind in der Sprachdatei definiert - also z.B. includes/lang/de.php


*Dumme Admin Frage :P

Habe deine "de.php" kopiert, umbenant folgende Änderung in der neuen Datei gemacht:
/* translation of member status options */
$STATUS['Admin'] = 'Herr des Bösen';

und diese dann als Sprachdatei im Adminbereich ausgewählt.


Leider steht im Forum unter dem Bildchen immer noch Admin und nicht "Herr des Bösen"... War wohl nicht weit genug gedacht nehm ich an- kann man den Namen "Admin" überhaupt in der Sprachdatei anpassen?

Das klingt nach einem Bug, werde ich mir ansehen.


Originally posted by moo2 at 19:54 on June 25th, 2009:
Was bedeutet im Adminbereich unter "Benutzergruppen" dieses "Öffentlich" - den Haken kann ich nur im letzen Feld machen wo noch nichts eingetragen ist bei admin und co. läßt sich kein Haken setzen.

Siehe dazu meine Erklärung hier in diesem Thema :P

Originally posted by Mr Creosote at 06:50 on June 24th, 2009:
Genauso kannst du natürlich weitere Gruppen anlegen, und diesen dann andere Rechte auf Foren zuteilen. Hierbei müsstest du dich dann entscheiden, ob die Gruppen öffentlich sind (d.h. jeder kann selbst beitreten) oder nicht (d.h. nur Admins können Mitgliedern neue Gruppen zuteilen).


Ich denke, damit erübrigt sich die Frage, warum du "Admin" nicht als "öffentlich" definieren kannst ;)
-----
Now you see the violence inherent in the system!
Posted at 19:54 on June 25th, 2009 | Quote | Edit | Delete
Avatar
Member
Bachelor Gumby
Posts: 73
Quote:
Die Übersetzungen der Gruppennamen sind in der Sprachdatei definiert - also z.B. includes/lang/de.php


*Dumme Admin Frage :P

Habe deine "de.php" kopiert, umbenant folgende Änderung in der neuen Datei gemacht:
/* translation of member status options */
$STATUS['Admin'] = 'Herr des Bösen';

und diese dann als Sprachdatei im Adminbereich ausgewählt.


Leider steht im Forum unter dem Bildchen immer noch Admin und nicht "Herr des Bösen"... War wohl nicht weit genug gedacht nehm ich an- kann man den Namen "Admin" überhaupt in der Sprachdatei anpassen?


Zweite und letzte Frage :)
Was bedeutet im Adminbereich unter "Benutzergruppen" dieses "Öffentlich" - den Haken kann ich nur im letzen Feld machen wo noch nichts eingetragen ist bei admin und co. läßt sich kein Haken setzen.
-----
Never be afraid to try something new. Remember that amateurs built the Ark. Professionals built the Titanic.
Posted at 21:18 on June 24th, 2009 | Quote | Edit | Delete
Avatar
Admin
Reborn Gumby
Posts: 8814
Originally posted by moo2 at 17:46 on June 24th, 2009:
Uff - das mit den Zugriffsrechten muß ich mir erstmal durch den Kopf gehen lassen ;)

Wenn ich das richtig verstanden habe gebe ich der Gruppe "Member" lese und schreibzugriff auf ein Forum und die Gruppen Mods und Admins haben dann automatisch die selben rechte - weil sie in der Liste weiter oben stehen :)

Richtig, wobei das eben nur auf "Member" zutrifft. Admins haben nicht automatisch die Rechte von Moderatoren usw.

Originally posted by moo2 at 17:46 on June 24th, 2009:
Die Gruppennamen kann ich wohl nur direkt in einer Konfigurationsdatei ändern nehme ich an - zumindest sind sie bei mir ausgegraut. "Memberstages" schein frei definierbar zu sein.

Die vordefinierten Gruppen sind intern von essentieller Bedeutung - deshalb kann man sie nicht editieren oder löschen. Die Stufen dagegen sind reine Makulatur - da dürfen dumme Admins ruhig rumpfuschen ;) Die Übersetzungen der Gruppennamen sind in der Sprachdatei definiert - also z.B. includes/lang/de.php.

Originally posted by moo2 at 17:46 on June 24th, 2009:
gar nicht so einfach die Zeilennummer zu finden wenn keine dranstehen

Du solltest dir dringenst einen vernünftigen Texteditor zulegen... jeder normale zeigt Zeilennummern an!

Originally posted by moo2 at 17:46 on June 24th, 2009:
Diesmal bekomme ich mit dem FF eine weiße seite angezeigt - dabei habe ich mich mir dem browser noch kein einziges mal versucht anzumelden oder sonst was... Opera und Safari funkionieren. Seltsam das alles ;)

Das liegt sehr wahrscheinlich daran, dass du in Firefox noch irgendeinen alten Cookie von einer der alten Installationen hast. Das bringt jetzt natürlich alles durcheinander. Einfach mal alle Cookies von der URL löschen.

Originally posted by moo2 at 17:46 on June 24th, 2009:
Ich frag mich immer noch wie du da die einstellungen an der datenbank verstellen kontest, obwohl man bei den Settings gar nichts abspeichern konnte :P

Wenn man es wirklich will, kann man alles erreichen - oder, wenn man genau weiß, was man tut ;)
-----
Now you see the violence inherent in the system!
Posted at 17:46 on June 24th, 2009 | Quote | Edit | Delete
Avatar
Member
Bachelor Gumby
Posts: 73
Uff - das mit den Zugriffsrechten muß ich mir erstmal durch den Kopf gehen lassen ;)

Wenn ich das richtig verstanden habe gebe ich der Gruppe "Member" lese und schreibzugriff auf ein Forum und die Gruppen Mods und Admins haben dann automatisch die selben rechte - weil sie in der Liste weiter oben stehen :)

Die Gruppennamen kann ich wohl nur direkt in einer Konfigurationsdatei ändern nehme ich an - zumindest sind sie bei mir ausgegraut. "Memberstages" schein frei definierbar zu sein.


Oh und hey - vielen Dank - das Board scheint nach deinen Änderungen zu laufen(gar nicht so einfach die Zeilennummer zu finden wenn keine dranstehen - zum Glück gibts die Suchfunktion ;)). Wieder zu finden unter .../spamboard
Diesmal bekomme ich mit dem FF eine weiße seite angezeigt - dabei habe ich mich mir dem browser noch kein einziges mal versucht anzumelden oder sonst was... Opera und Safari funkionieren. Seltsam das alles ;)

Aber hey es läuft - TOLL - freut mich um ehrlich zu sein mehr als die Installation des SMF Forums welches gleich out of the box lief :)
Ich frag mich immer noch wie du da die einstellungen an der datenbank verstellen kontest, obwohl man bei den Settings gar nichts abspeichern konnte :P
-----
Never be afraid to try something new. Remember that amateurs built the Ark. Professionals built the Titanic.
-----
Edited by traeumer at 17:48 on June 24th, 2009
Posted at 06:50 on June 24th, 2009 | Quote | Edit | Delete
Avatar
Admin
Reborn Gumby
Posts: 8814
Originally posted by moo2 at 05:27 on June 24th, 2009:
<td class="recent"><h3><a href="index.php?show=topic&id=2">Blub</a></h3></td> 1 0 <td class="recent"><div>by <a href="index.php?show=profile&id=1">traeumer</a></div><div>at 19:08</div><div>on June 23rd, 2009</div></td> <td class="recent"><div>by <a href="index.php?show=profile&id=1">traeumer</a></div><div>at <a href="index.php?show=topic&id=2&amp;page=1#newpost">19:08</a></div><div>on June 23rd, 2009</div></td>

Am Maintanace-Modus liegt? Könnte ich mir gut vorstellen und fällt mir erst jetzt auf :(

Eigentlich nicht, nein. Das ist bereits beim Schreiben falsch gespeichert worden.

Originally posted by moo2 at 05:27 on June 24th, 2009:
Änderungen an den Settings kann ich über die GUI leider trotzdem nicht vornehmen - hab dir ja schon ein Nacricht wegen den testzugangsdaten geschickt - vielleicht läuft es ja doch irgendwann :)

Der Bug ist schonmal gefunden (siehe Nachricht) :)

Originally posted by moo2 at 05:27 on June 24th, 2009:
Wenn ich das richtig sehe, dann kann ich Foren für bestimme User "sperren", indem ich Ihnen unter Edit Groups an den Zugriffsrechten spiele, richtig oder kann man nur foren einrichten die für alle zugänglich sind?

Im Folgenden benutze ich "Forum" in Sinne wie hier "Deutsches Forum" - nicht "Spam Club" (das würde ich der Eindeutigkeit als "Board" bezeichnen).

Du kannst pro Forum die Zugriffsrechte pro Benutzergruppe festlegen. Ein neuangelegtes Forum erlaubt erstmal niemandem Zugriff und ist deshalb auch für niemanden überhaupt sichtbar (also kann man nicht nur nicht die Beiträge lesen, sondern erkennt auch gar nicht die Existenz des Forums). Du musst Rechte also positiv und aktiv vergeben.

Mit Hilfe der vorgegebenen Gruppen kannst du natürlich nur zwischen Gästen, normalen Mitgliedern und Moderatoren / Admins unterscheiden. So könnte man z.B. ein Forum anlegen, in das nur Admins reinkommen. Genauso kannst du natürlich weitere Gruppen anlegen, und diesen dann andere Rechte auf Foren zuteilen. Hierbei müsstest du dich dann entscheiden, ob die Gruppen öffentlich sind (d.h. jeder kann selbst beitreten) oder nicht (d.h. nur Admins können Mitgliedern neue Gruppen zuteilen). Achtung: Die Gruppe "Member" / "Mitglied" skaliert, d.h. jeder Admin, Moderator usw. ist auch "Member". Jedes registrierte Mitglied um genau zu sein, unabhängig von weiteren Gruppenmitgliedschaften.

Bestimmte Rechte für "bestimmte User", wie du es formuliert hast, kann man theoretisch damit auch indirekt umsetzen: Du könntest für jeden Benutzer natürlich eine eigene (nicht öffentliche) Gruppe anlegen und dieser "Gruppe" dann Rechte geben. Wird aber aufwändig ;)
-----
Now you see the violence inherent in the system!
Posted at 05:27 on June 24th, 2009 | Quote | Edit | Delete
Avatar
Member
Bachelor Gumby
Posts: 73
Kann es vielleicht sein, dass die Darstellung der Posts in Form von:
<td class="recent"><h3><a href="index.php?show=topic&id=2">Blub</a></h3></td> 1 0 <td class="recent"><div>by <a href="index.php?show=profile&id=1">traeumer</a></div><div>at 19:08</div><div>on June 23rd, 2009</div></td> <td class="recent"><div>by <a href="index.php?show=profile&id=1">traeumer</a></div><div>at <a href="index.php?show=topic&id=2&amp;page=1#newpost">19:08</a></div><div>on June 23rd, 2009</div></td>

Am Maintanace-Modus liegt? Könnte ich mir gut vorstellen und fällt mir erst jetzt auf :(

Änderungen an den Settings kann ich über die GUI leider trotzdem nicht vornehmen - hab dir ja schon ein Nacricht wegen den testzugangsdaten geschickt - vielleicht läuft es ja doch irgendwann :)

Wenn ich das richtig sehe, dann kann ich Foren für bestimme User "sperren", indem ich Ihnen unter Edit Groups an den Zugriffsrechten spiele, richtig oder kann man nur foren einrichten die für alle zugänglich sind?
-----
Never be afraid to try something new. Remember that amateurs built the Ark. Professionals built the Titanic.
Posted at 20:20 on June 23rd, 2009 | Quote | Edit | Delete
Avatar
Admin
Reborn Gumby
Posts: 8814
Es sollte immer funktionieren mit sämtlichen Sonderzeichen - nur wieder etwas, was tendenziell wenig getestet wird...

Edit: Meine zweite Testinstallation, bei der ich mal einfach in alle Felder "äöüß" eingegeben habe, hat ebenfalls geklappt. Das Problem muss also tiefer liegen. Näheres in deinem Nachrichtenfach.
-----
Now you see the violence inherent in the system!
-----
Edited by Mr Creosote at 20:32 on June 23rd, 2009
Posted at 20:18 on June 23rd, 2009 | Quote | Edit | Delete
Avatar
Member
Bachelor Gumby
Posts: 73
Mist - ich hab EIN Sonderzeichen drin und zwar ein "ö" - wir zwar auf der Seite richtig angezeigt aber wer weis.
Da das Forum erstmal rein zum testen und probieren läuft schick ich dir den Link mal via PN - möchte hier keine "Werbung" ;) machen.
-----
Never be afraid to try something new. Remember that amateurs built the Ark. Professionals built the Titanic.
Posted at 20:14 on June 23rd, 2009 | Quote | Edit | Delete
Avatar
Admin
Reborn Gumby
Posts: 8814
Das Installationsskript ist der am wenigsten getestete Teil des Boards (weil es nicht so viele Spam Boards gibt - die paar wenigen werden eben immer nur aktualisiert und nie neu installiert), so dass es immer sein kann, dass da auch mal böse Bugs unbemerkt bleiben.

Ich habe allerdings eben mal eine Testinstallation mit der Version durchgeführt, und es läuft alles (auf den ersten Blick). Spontan tippe ich auf ein Zeichensatzproblem. Hast du irgendwo Sonderzeichen drin (egal wo)? Schränkt dich der Webserver irgendwie bzgl. Zeichensätzen ein?

Darüber hinaus könnte es helfen, wenn du mir mal die URL der Testinstallation sagst (auch gerne per privater Nachricht, wenn das noch niemand sehen soll).
-----
Now you see the violence inherent in the system!
Powered by Spam Board 5.2.4 © 2007 - 2011 Spam Board Team