Game:

The Spam Club

» The Spam Club - Life, The Universe and Everything - Site Issues - Downtime, problems etc.
ReplyNew TopicNew Poll

Downtime, problems etc.

Posted at 11:35 on January 19th, 2005 | Quote | Edit | Delete
Avatar
Admin
Reborn Gumby
Posts: 8814
I'm working on it. Stay tuned, long explanation to follow.
-----
Now you see the violence inherent in the system!
Posted at 11:41 on January 19th, 2005 | Quote | Edit | Delete
Avatar
Admin
Reborn Gumby
Posts: 8814
All problems I found user-side should be fixed now. There's still an issue with administration, but please also report any errors you get in the forum and on the site.
-----
Now you see the violence inherent in the system!
Posted at 12:36 on January 19th, 2005 | Quote | Edit | Delete
Avatar
Member
Retired Gumby
Posts: 940
Good to see the site is slowly coming back. My daily browsing habits have been significantly confused during the past few days. ;)
Posted at 13:17 on January 19th, 2005 | Quote | Edit | Delete
Avatar
Admin
Reborn Gumby
Posts: 8814
Ok, I think I've solved the authentification problem, too, so all administrative functions of both the site and the forum should now work again. So here's the long story:

In December of last year, my host announced to shut down at the end of February. Although I wasn't too happy about that, I planned to look for a new host in early February to have enough time to move all hosted sites without pressure.

On Friday evening (last week), all sites had suddenly disappeared from the net, showing the message about the account being suspended. I couldn't log in to my e-mail account, via FTP or even to the hosting administration frontend anymore. Of course, I immediately tried contacting both technical support and sales department to find out what the problem was.

On Saturday, a few of the hosted sites suddenly started working again. Others (including TGOD) didn't. I wrote yet another e-mail to technical support. Nothing happened on Sunday. Another e-mail sent. Nothing happened on Monday. Another e-mail sent.

When nothing happened on Tuesday, either, I got fed up, and I signed up with another host. I immediately got the login data, and started setting up the site again there, using the latest database backup (from about a week before the crash, so some recent forum posts have been lost, unfortunately). As for the forum script, I just uploaded what I presumed to be the correct version. It was late, the DNS wasn't yet resolving, so I didn't / couldn't properly check whether everything was working.

Today, I was glad to see the DNS was already resolving to the new server from my university. I also noticed several 'Internal Server Errors' in the forum, but I couldn't fix them without access to my home computer. So I did that when I got home.

Last, but not least, this new webserver has PHP compiled not as an Apache module, but as CGI, so I had to work out an alternative to the HTTP authentification I've been using for the admin sections so far.

Anyway, let's hope this server proves to be more stable and this hosting company more reliable than the last one. Again, report any errors when you find them. NetDanzr: Please contact me, then we'll set your site up again.
-----
Now you see the violence inherent in the system!
Posted at 14:57 on January 19th, 2005 | Quote | Edit | Delete
Avatar
Member
Dr Gumby
Posts: 261
At last! :D

It's only sad for all my higly intelligent, humorous and most important posts... :embarassed:
-----
Being fat is no illness, but ideology
Posted at 14:58 on January 19th, 2005 | Quote | Edit | Delete
Avatar
Admin
Reborn Gumby
Posts: 8814
Apparantely, a few avatars have been lost, too. I guess you can upload those again without many problems, though ;)
-----
Now you see the violence inherent in the system!
Posted at 16:20 on January 19th, 2005 | Quote | Edit | Delete
Avatar
Member
Retired Gumby
Posts: 940
Uploading avatars doesn't seem to work right now ("Internal Server Error").
Posted at 17:54 on January 19th, 2005 | Quote | Edit | Delete
Avatar
Member
Prof Gumby
Posts: 488
Nice to see everything is going back nicely.

You seems to have a heavy history when it comes to server host disapointment... :(
-----
I am on a hot streak... Litterally.
Posted at 19:02 on January 19th, 2005 | Quote | Edit | Delete
Avatar
Member
Retired Gumby
Posts: 936
I sadly typed in the url every single day despite knowing in the back of my head that it was down for a bit. ;)
-----
Keep your stick on the ice
Posted at 01:38 on January 20th, 2005 | Quote | Edit | Delete
Avatar
Member
Prof Gumby
Posts: 607
Good to see the site and forums are back, I have to admit I was getting scared. :)
-----
"One Very Important Thought"
Posted at 07:22 on January 20th, 2005 | Quote | Edit | Delete
Avatar
Member
Prof Gumby
Posts: 411
phew...Back again! :)
-----
If it ain't broken, you're not trying hard enough.
Posted at 10:43 on January 20th, 2005 | Quote | Edit | Delete
Avatar
Admin
Reborn Gumby
Posts: 8814
Quote:
Posted by Tapuak at 00:20 on January, 20th 2005:

Uploading avatars doesn't seem to work right now ("Internal Server Error").
Should be fixed.

Quote:
You seems to have a heavy history when it comes to server host disapointment...
Too true, unfortunately :( Partly, this is due to the several times I took private hosting offers from other webmasters who simply can't guarantee perfect service. Last time, it was a company which had been in business since 1998, though, which makes it even worse :angry:
-----
Now you see the violence inherent in the system!
Posted at 11:04 on January 20th, 2005 | Quote | Edit | Delete
Avatar
Member
Retired Gumby
Posts: 940
Quote:
Should be fixed.

Yeah, working. :)
Posted at 12:01 on January 20th, 2005 | Quote | Edit | Delete
Guest
Safe to resume breathing again? Good.
Posted at 06:23 on January 24th, 2005 | Quote | Edit | Delete
Avatar
Member
Retired Gumby
Posts: 964
Good to see it back. I've had similar problems with a host (Fuitadnet), but it took much longer to have them resolved. The account got flagged and disabled, and it took them nearly a month to figure out why it's been flagged in the first place (turns out they didn't like a PHP script that sent me an e-mail whenever somebody hit the "Submit" button).

Still, the worst experience I've had was with a company called X-Gravity. Here's what they sent me one day:

Quote:
Over the last 15 hours we have been trying to recover data on Hercules(69.90.174.130) from a hard drive gone bad to no avail. Due to the way the server itself was put together, the hard drives were on the wrong IDE controllers causing errors that eventually led to it being rendered useless. We are very sorry that this happened but no files were able to be recovered.

We are not able to get backups as they were on the
server as well. We will be cancelling all subscriptions for those that were on hercules. As there is nothing we can do anymore, we wish you the best of luck with your new host.
-----
NetDanzr<br />
-The quick brown fox jumps over the lazy dog-
Posted at 06:30 on January 24th, 2005 | Quote | Edit | Delete
Avatar
Admin
Reborn Gumby
Posts: 8814
Quote:
it took much longer to have them resolved
The issues of the old host still aren't resolved. I've just given up waiting for them ;)
-----
Now you see the violence inherent in the system!
ReplyNew TopicNew Poll
Powered by Spam Board 5.2.4 © 2007 - 2011 Spam Board Team